Packet Tracer 6 Activity – Basic IPv6 Network

Overview

This Packet Tracer 6.0.1 and 6.1 networking activity involves setting up a basic IPv6 network by interconnecting two Cisco 1941 routers, two Cisco Catalyst 2960 switches, and two PCs. All of the devices in the network will need to be configured with IPv6 addressing in order to communicate. The goal is to configure the routers and PCs with the following information:

{loadposition adposition5}• On the routers configure basic security with hostnames, console and vty passwords, banner message of the day, and enable password encryption (see the network diagram in Packet Tracer),
• On the routers configure link-local and global unicast IPv6 addresses with network prefix lengths (see the network diagram),
• On the routers configure static IPv6 default routes (see the network diagram),
• On the PCs configure static IPv6 addresses with network prefix lengths, and a gateway address (see the network diagram),
• Follow the instructions in the network diagram for additional required configurations

The scoring is based on the total number of items correctly configured. Remember that when entering configurations the system is case sensitive. When you are finished, you should be able to communicate across the network (e.g. successfully ping PCB from PCA)

Download

BasicIPv6NetworkConfiguration_6.1.zip

Notes: This version fixes the incorrect grading of the IPv6 link-local address of the R2 G0/1 interface You will need Packet Tracer version 6.1 to open this activity

BasicIPv6NetworkConfiguration.zip

Notes: There is incorrect grading of the IPv6 link-local address on the R2 G0/1 interface. Change it to FE80::1 to receive 100%. You will need Packet Tracer version 6.0.1 to open this activity.

 

Spoiler Alert – Only Read Below if you are stuck

IOS Command List

router>enable
router#configure terminal
router(config)#hostname R1
R1(config)#banner motd “No unauthorized access allowed!”
R1(config)#enable secret class
R1(config)#service password-encryption
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#ipv6 unicast-routing
R1(config)#interface g0/0
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:ACAD:2::1/64
R1(config-if)#description toR2
R1(config-if)#no shut
R1(config)#interface g0/1
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:ACAD:1::1/64
R1(config-if)#description toLAN
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ipv6 route ::/0 2001:DB8:ACAD:2::2
R1#copy running-config startup-config
R1#show running-config
R1#show ipv6 route
R1#show ipv6 int brief

router(config)#hostname R2
R2(config)#banner motd “No unauthorized access allowed!”
R2(config)#enable secret class
R2(config)#service password-encryption
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#ipv6 unicast-routing
R2(config)#interface g0/0
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:ACAD:2::2/64
R2(config-if)#description toR2
R2(config-if)#no shut
R2(config)#interface g0/1
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:ACAD:3::1/64
R2(config-if)#description toLAN
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#ipv6 route ::/0 2001:DB8:ACAD:2::1
R2#copy running-config startup-config
R2#show running-config
R2#show ipv6 route
R2#show ipv6 int brief

Packet Tracer 6 Activity – Basic IPv4 Network

Overview

This virtual networking activity involves setting up a basic IPv4 network by connecting two Cisco 1941 routers to two Cisco Catalyst 2960 switches to two PCs. The goal is to variously configure the PCs, switches, and routers with the following information:

{loadposition adposition5}• Basic network device security, by configuring access port passwords, banner message of the day and encryption on the routers and switches (see the network diagram in Packet Tracer),
• Interface IP address, subnet mask, and gateway addresses (see the network diagram in Packet Tracer),
• A static default route/gateway of last resort for the routers,
• Follow the instructions in the network diagram for additional required configurations

The scoring is based on the total number of items correctly configured. Remember that when entering configurations the system is case sensitive. In the end, you should be able to ping from PCA to PCB

Download

BasicIPv4NetworkConfiguration.zip

Note: You will need Packet Tracer version 6.0.1 to open this activity

 

Spoiler Alert – Only Read Below if you are stuck

IOS Command List

router>enable
router#configure terminal
router(config)#hostname R1
R1(config)#banner motd “No unauthorized access allowed!”
R1(config)#enable secret class
R1(config)#service password-encryption
{loadposition adposition5}R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface g0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#description toR2
R1(config-if)#no shut
R1(config)#interface g0/1
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#description toLAN
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.2
R1#copy running-config startup-config
R1#show running-config
R1#show ip route
R1#show ip int brief

switch>enable
switch#configure terminal
switch(config)#hostname S1
S1(config)#banner motd “No unauthorized access allowed!”
S1(config)#enable secret class
S1(config)#service password-encryption
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 14
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#interface vlan 1
S1(config-if)#ip address 192.168.0.2
S1(config-if)#exit
S1(config)#ip default-gateway 192.168.0.1

S1(config)#exit
S1#copy running-config startup-config
S1#show running-config

Standard ACL Packet Tracer Challenge

Packet Tracer Challenge Overview

Learn the basics of using standard access lists with these Packet Tracer graded activities. In the activities, the networks have been pre-configured. All you need to do is write the access list, and decide where to apply it. Open the Packet Tracer files, follow the written instructions and the instructions on the topology diagrams.

Standard ACL Practice #1

In this Packet Tracer exercise, the goal is to create a simple standard ACL to permit one network and block the other. Follow the written instructions on where to apply the access list.

Download

The Packet Tracer file is created with Packet Tracer 5.3.3. The Packet Tracer Activity file will track your progress and give you a completion percentage and point total. You can download it here: standardACL-practice1.zip

Standard ACL Practice #2

In this exercise the goal is to permit two hosts, one from the yellow network and one from the blue network, to reach the green network. In this exercise you need to figure out where to apply the ACL so that the intended networks are effected. Hint: standard ACL are usually applied closest to the destination network effected.

 

Download

The Packet Tracer file is created with Packet Tracer 5.3.3. The Packet Tracer Activity file will track your progress and give you a completion percentage and point total. You can download the file here: standardACL-practice2.zip

Switch & VLAN Packet Tracer Challenge

Switch & VLAN Packet Tracer Challenge Overview

A Packet Tracer graded activity. It covers basic Cisco CCNA switch configurations, VLANs, native VLAN, trunk ports, port-security, and setting up secure remote administration with SSH. Great practice for the the Cisco CCNA!

Download

The Packet Tracer file is created with Packet Tracer 5.3.3. The Packet Tracer Activity file will track your progress and give you a completion percentage and point total. You can download it here: BasicConfig-VLAN-Trunk-PortSec-SSH-challenge.zip

Activity Instructions

Configure the Network according to the Topology Diagram and Labels.
When you are finished, the PCs on the Student VLAN should be able to ping each other and so should the PCs on the Faculty VLAN. The Admin PC should be able to SSH into S1 and S2 from the command prompt (Eg. PC>ssh -l admin 192.168.99.2)

PCs
1. IP address (see topology),
2. subnet mask (see topology),
3. default gateway address (first usable address in network)

Cisco 2960 Switches: S1 & S2
1. name: S1, S2
2. enable password, md5 encrypted: class
3. domain name: danscourses.com
4. message of the day banner: Unauthorized access is prohibited!
5. console password: cisco
6. vty 0 15 password: cisco
7. Security RSA Key size: 1024
8. SSH version 2
9. vty: ssh only
10. VLAN 10: student
11. VLAN 20: faculty
12. VLAN 99: Mgt
13. Interface VLAN 99: S1-IP address 192.168.99.2, S2-IP address 192.168.99.3
14. Native VLAN 99
15. fa0/1 Trunk
16. fa0/2-0/13 access VLAN 10
17. fa0/14-0/24 access VLAN 20
18. Gi1/1 access VLAN 99
19. Encrypt all passwords
20. Save running-config to startup-config

Cisco 2960 Switch: S1 Only
1. Gi1/1 Switchport Port-Security, sticky, maximum 1 mac address, violation shutdown

RIPv2 Packet Tracer Lab

Instructions

1. This is a classless addressing scenario (VLSM-CIDR), so you need a classless routing protocol. For this lab use RIPv2.
2. The lab topology has discontiguous networks, so you will need to disable RIP auto-summary.
3. R2 needs to have a default static route to the internet through the ISP router. Use the next hop ip address.
4. R2 needs to tell the other routers about its default route.
5. R2’s Fast Ethernet 0/1 interface should be passive.
6. Use passive-interface in order to not send routing updates to the LANs.
7. The ISP router should not use RIP, but instead use three static routes, two of the static routes should be summary routes.
8. The routers with DCE interfaces should have the clock rate set to 64000
9. The router’s serial DTE interfaces should have the first usable ip address in the network and the DCE interfaces should have the second usable ip address in the network.
10. All router LAN interfaces should have the first usable address in the network.
11. All PCs should have the x.x.x.10 host ip address.
12. Configure hostnames on all of the routers.

RIP Commands

R2(config)#router rip
R2(config-router)#version 2 //change to RIP version 2
R2(config-router)#no auto-summary //turn off default route summarization
R2(config-router)#network //advertises a connected network to neighboring RIP routers
R2(config-router)#network
R2(config-router)#network
R2(config-router)#default-information originate //distribute a default route to neighboring RIP routers
R2(config-router)#passive-interface //stops RIP from advertising routes out of an interface
R2(config-router)#end

Packet Tracer Graded Exercise

RIPv2_with_summary_routes.zip

Configure the Network with RIP Packet Tracer Challenge

Overview

In the lab, we configure a network topology which includes three Cisco 1841 or 1941 routers, three Cisco 2960 switches, and three PCs. The three routers need to be connected to each other over serial connections. {loadposition adposition5}Each router also needs to be  connected to a switch over a fast ethernet (1841) or gigabit ethernet port (1941). Each PC needs to be connected to a switch. The goal of the lab is to do the following things:

1) Wire all of the devices in the network as instructed,
2) Configure the ip addressing and names of all of the devices as instructed,
3) Configure the devices using CLI commands as instructed,
4) Configure RIP so all devices can communicate over the network,
5) Verify that all PCs can communicate with each other over the network

I have created a Packet Tracer Activity which has all of the lab instructions included in it and will also check your results when you are finished. You will need Packet Tracer version 5.3.3. You can download the activity by clicking here, : CCNA2_Configure_the_Network_Challenge_1b.zip

Here is an image of the network topology at the start of the activity lab.

 

Lab Outline

1) Wire the network. The serial interfaces with .2 as the address should be the DCE.
2) Configure the ip addressing and names of all of the devices as shown in the topology
3) Configure the devices using the commands listed below
4) Configure RIP so all devices can communicate over the network

Notes:
• Login passwords should be “cisco” (no quotes)
• Enable secret should be “class” (no quotes)
• Clock rates should be set to 64000
• Interface descriptions should be based on the connected network subnet like: “network-1”, “network-2”, up to “network-6”
• commands not listed below are: “enable” are “configure terminal”
• Start wiring the local area networks from the PCs using first available ethernet ports. PC1 to S1(fa0/1) and S1(fa0/2) to R1(fa0/0). Start wiring serial ports clockwise starting from R1(0/0/0) to R2 (0/0/0), R2(0/0/1) to R2 (0/0/0), etc.. (Remember the .2s should be the DCEs.)
• PCs should be configured with .10 host addresses, switches with .2 host addresses, and routers with .1 and .2 host addresses (refer to diagram)

Router Commands

hostname <name>
banner motd <#No unauthorized access!#>
enable secret <password>
line console 0
password <password>
login
line vty 0 4
password <password>
login
int fa 0/0
ip address <ip addr> <mask>
description <description>
no shut
int s 0/0/0
ip address <ip addr> <mask>
clock rate <rate num> (only if the interface is the DCE)
description <description>
no shut
int s 0/0/1
ip address <ip addr> <mask>
clock rate <rate num> (only if the interface is the DCE)
description <description>
no shut
router rip
network <net address>
network <net address>
network <net address>
copy running-config startup-config

Switch Commands

hostname <name>
banner motd <#No unauthorized access!#>
enable secret <password>
line console 0
password <password>
login
line vty 0 15
password <password>
login
int vlan 1
ip address <ip addr> <mask>
no shutdown
ip default-gateway <ip addr>
copy running-config startup-config

Subnetting PT Network Challenge

Subnetting with Packet Tracer Overview

Packet Tracer is a great network simulation tool that is made available to Cisco Academy students. It is ideal for quickly testing networking concepts and learning. In this Packet Tracer Skills Assessment (.pka) you will need to subnet a network into 7 subnet address ranges, configure the network devices and hosts with those addresses, set up static and default routes, and set up HTTP and DNS services on a host server.

If you have Packet Tracer 5.3.3  you can download, extract, and run the zipped .pka file below. Read the built in instructions. When you have finished configuring the network you should be able to ping the server from the PC hosts as well as open the www.cisco.com web page from host PC0 or PC1s simulated web browser.

In the activity you will need to create the following 7 subnets from the 172.16.0.0 /22 network address range:

1st subnet 400 hosts,
2nd subnet 180 hosts,
3rd subnet 40 hosts,
4th subnet 18 hosts,
5th subnet WAN Point to Point (4 hosts),
6th subnet WAN Point to Point (4 hosts),
7th subnet WAN Point to Point (4 hosts),

Screenshot of configure_the_network.pka activity

 

Download

Configure_the_Network_Challenge_7.zip

Application Layer PT Server Activity

Application Layer – Server Activity Overview

It is important to know the basic functions of the various networking programs that operate at the Application Layer. The average person uses these Application Layer programs on a daily basis without ever wondering about how they fit into the layered networking models of the OSI and TCP/IP models. These Application Layer services continue to be important as we learn about how they correspond to source and destination port numbers within the Transport Layer header. 

Cisco Packet Tracer Activity

Set up the following services on the servers in Packet Tracer: DHCP, DNS, HTTP (Web), FTP, and Mail. If you configure everything correctly you should be able to: receive ip addressing to the DHCP clients from the DHCP server, resolve domain name requests from the DNS server, successfully receive requested web pages from the web server, upload and download files after logging into the FTP server, and send and receive email to and from the mail server. Here is a rough outline of the steps involved:

  1. Physically connect all of the devices with appropriate cables,
  2. Configure IP addressing on all of the networking devices (follow the device labels),
  3. Configure the server services on the devices as listed (dhcp, dns, mail, web, ftp),
  4. Verify that all of the configured services work by testing from the client computers,
  5. Note: In this Cisco PT activity the services and testing do not extend beyond the LAN i.e. router.

Download the start file here: PT_working_w_servers_begin.zip ,
the finished version is here: PT_working_w_servers_end.zip
Packet Tracer version 5.3.3

 

Video Tutorials

Cable the network, configure IP addressing, and DHCP services

Configure and test HTTP and DNS services

Configure and test the FTP service

Configure and test Mail services