Welcome to CCNA 1

Cisco CCNA 1 Introduction

The Cisco CCNA certification is the most well known computer networking certification in the industry. I recommend a Cisco CCNA Routing and Switching course of study. The Cisco Academy Curriculum in particular for anyone who wants to learn about computer networking. It is the best foundation for learning about network communication protocols, network addressing including IPv4 and IPv6, subnetting, routing, switching, VLANs and more!

I have taught the Cisco CCNA curriculum, as a Cisco Academy instructor for over 14 years. The Cisco Academy offers 4 courses that together map to the Cisco CCNA certification exam. The current exam is the 200-120 CCNA which has a stronger emphasis on IPv6. All of the students that sign up for a class through the college will be automatically enrolled in the Cisco Academy, and all Cisco Academy students will have access to online curriculum as well as the latest version of Packet Tracer. Packet Tracer is a program for creating simulated networked environments, complete with functioning routers, switches, and endpoint hosts.

Most of all, the Cisco Academy releases regular version updates to their CCNA Routing and Switching curriculum and the recently updated curriculum coincides with the new 200-125, CCNA Routing and Switching exam. The new curriculum covers new exam topics such as, IPv6, VTP, LLDP, eBGP, PPPoE, QoS, SNMPv3, NTP, DMVPN, SPAN, SDN, virtualization and Cloud computing.

CCNA 1 – Course Materials

As a Cisco Networking Academy student, all of the course materials are available through the Academy website learning management system. Including the complete text, the Packet Tracer network simulator, interactive activities, multiple choice exams, and plenty of labs with complete step-by-step instructions. If you prefer a paper copy of the text you can purchase it online from Cisco Press or Amazon. Make sure you order a current version of the text. Here is a link to the text
at Cisco Press and the ISBN number:

Introduction to Networks Companion Guide: Print ISBN: 978-1-58713-316-9, eBook: ISBN: 978-0-13347-544-9

Introduction to Networks | Cisco CCNA | Cisco Press

Class Availability

  • Where can I enroll in a class?
    I recommend looking for a Cisco Academy nearest you. That way, you take an in-person class, and get to work on physical equipment within the classroom environment. Finally, I teach the Cisco CCNA through Central Oregon Community College. The CCNA 1 class begins in the Fall quarter with CCNA2 and CCN3/4 following in the Winter and Spring respectively. Sign up for a class! You can even attend remotely online. Look for new student registration information at http://www.cocc.edu.
  • Where can I do my labs?.
    Some labs are done in class, some labs are done at home using Packet Tracer, and some labs are done by remotely by connecting to the CIS Department Netlab+ server.
  • I am an online student, and I can’t come to the lab?
    If you are an online student, I recommend that you login to Blackboard and attend class online using the Blackboard Collaborate video conference tool. The class is always available through video conference and each class is recorded for downloading or streaming at a later date.
  • How do I turn in assignments?
    Students take exams online through the Cisco Netacad website and learning management system. Labwork and homework is turned in through Blackboard or the Netacad website.
  • How are assignments graded?
    I grade on a point system. Every week you have the opportunity to
    earn points from chapter exams and chapter labs. At the end of the class there is a cumulative multiple choice final exam as well as a hands-on lab final.

Network Troubleshooting PT Activity

Overview

It is important to know how to troubleshoot network connectivity issues. How to configure PCs to add them to the network? What tools can you use from the command prompt to test connectivity and check your network address settings? In order to test your skills, I created a Packet Tracer 6.1 activity in which you are the network administrator and you need to troubleshooting the network and answer some fundamental questions about the network. I have included the Packet Tracer activity file for you to download as well as the instructions below.

Instructions – Troubleshooting Activity

Troubleshooting Tasks
1. Fix PC1 and PC2 so they can reach the company website www.initech.com, and remote website www.danscourses.com.
2. Fix Laptop0 so it can associate with Wireless Router0, and connect to the wireless network

Initech Admin
vty password: swingline
enable secret: cubicle

Answer the Following Questions
1. What is the network address of the green network?
2. What is the network address of the orange network?
3. What is the IP address of the Initech webserver?
4. What is the IP address of the Initech Nameserver?
5. What is the IP address of the Initech Mail Server?
Hint: what is the subdomain name of the mail server?
6. What is the IP address of the danscourses.com Webserver?
7. What is the SSID of Wireless Router0?
8. What is the wireless security key?
9. What is the IP address of the WAN interface on the Edge Router?

Download

Click here to download the PT activity:  TroubleshootingActivity1.zip
To open the file you will need Packet Tracer 6.1

Basic Network Configuration PT Activity

Overview

This is a beginning network configuration activity in Packet Tracer 6.1. This activity is designed to challenge you with some basic Cisco IOS configurations using a Cisco 1941 router, two Cisco Catalyst 2960 switches, a TFTP server and two PCs. In this Packet Tracer activity you are asked to configure the following items:

Step 1. Assign IPv4 addresses, subnet masks and default gateways to PC-A, PC-B, and Server1

Step 2. Configure the router with the following settings:
– hostname: R1
– console password: cisco
– vty 0-to-4 password: cisco
– enable secret: class
– banner message of the day: Unauthorized access is not allowed!
– encrypt all passwords
– configure Gigabit Ethernet interfaces with:
— IPv4 addresses,
— subnet masks,
— descriptions (LAN-Management, LAN-Student)
— bring-up the interfaces
– save the running configuration

Step 3. Configure each switch with the following settings:
– hostname: S1, S2
– console password: cisco
– vty 0-to-15 password: cisco
– enable secret: class
– banner message of the day: Unauthorized access is not allowed!
– encrypt all passwords
– configure interface VLAN 1 with:
— IPv4 address,
— subnet mask,
— bring-up the interface
– default gateway IPv4 address
– save running configuration

Step 4. Copy the IOS and startup-config file on R1, to the Server1 TFTP server.

Lab Activity Diagram/Topology Packet Tracer - Screenshot

Download the Activity

 
BasicNetworkConfiguration-Activity2.zip

Beginning Network Addressing PT Activity

Overview

This is a beginning Packet Tracer 6.1 activity designed to get you familiar with working with Packet Tracer. Your goal in this Packet Tracer activity is to configure the following:

1.  Both PCs with IP addresses, subnet masks, and default gateways.
2.  Configure each switch with: a hostname, an IP address and subnet mask on the VLAN 1 interface, and bring up the VLAN 1 interface.
3.  Configure the router with: a hostname, and IP address and subnet mask on each gigabit ethernet interface, and bring up the interfaces.

Download

CCNA1-exercise1-activity.zip

Command Examples

switch> enable
switch# configure terminal
switch(config)# hostname S1
S1(config)# interface vlan 1
S1(config-if)# ip address 192.168.1.2 255.255.255.0
S1(config-if)# no shutdown

router> enable
router# configure terminal
router(config)# hostname R1
R1(config)# interface g0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown

Networking Basics

Overview

At the beginning of a course of study towards the Cisco CCNA, it is a good idea to have an understanding of basic networking terms and concepts. Here is a list of introductory concepts that you should be familiar with:

LAN – a local area network or LAN is a network that has the following characteristics. It usually exists within a home, building or group of buildings. It is usually administered and managed by a single entity, business, or organization. In addition, a LAN typically consists of some form of an Ethernet network, whether it is Fast Ethernet (100Mb), Gigabit Ethernet (1000Mb), and whether it is implemented in twisted pair copper cables, multimode fiber optic cables, or some form of wireless technology.

WAN – wide area networks are the networks that interconnect all of the local area networks. WANs are typically managed and controlled by internet service providers (ISPs). Instead of using Ethernet, WANs typically implement different technologies like DSL, Cable, T1 and T3 serial lines, PPP, Frame Relay, ATM, etc..

WANs/LANs – To simplify the differences between these two types of networks we can use the example of a wireless router. On the wireless router the LAN ports and the wireless antennas connect to the computers on your local network or LAN, and the WAN port connects to the modem which communicates with your internet service provider on the WAN.

Internet, Intranet, Extranet – What is the difference between the internet, an intranet, and an extranet?

Internet – inter means between, and net is short for networks, so internet literally means between networks. So what is the internet? The network of networks. The network formed by connecting all of the networks together.

Intranet – intra means within and net means network, so intranet means within the network. For instance, when I taught high school I wanted to have my own web server. The school district agreed to let me have my own web server for my students, but it had to be on the intranet only. This meant that the students could reach the webpages but from within the school only. The webserver was not on the internet.

Extranet – extra means in addition to, and net means network, so extranet literally means in addition to the network. An extranet is an area of the network that users who are outside of the network can remotely connect into. This can be done with VPN services, allowing users with permission to VPN into an area of the network.

CCNA1 Practice Final – Packet Tracer 6

Lab Overview – CCNA1 Practice Final

This virtual CCNA1 Practice Final lab activity is designed to test if you have skill and knowledge required to pass the Cisco Academy CCNA 6.0 – Introduction to Networking Final Skills Assessment. You will need to have at least Packet Tracer version 6.0.1 to open the activity file. The activity tracks your overall progress and provides feedback on correctly executed tasks. Here is a list of the knowledge and skill areas that it covers:

• Configuring IPv4 addressing and subnetting,
• Configuring IPv6 addressing,
• Basic network device configuration, for both routers and switches,
• Securing network device access, including security and encryption,
• Configuring secure remote access for administration,
• Backing up network device configuration files to a TFTP server

The scoring is based on the total number of items correctly configured (a few gradable items like the crypto-keys may not grade correctly in Packet Tracer). Remember that the Cisco IOS is case sensitive when entering configuration settings like hostnames and banner message of the day. When you are finished, you should be able to communicate across the network (e.g. successfully ping PC0 from PC2). In this PT activity access to the CLI tab has been disabled, so in order to configure the router and switches, you will need to console-in, using the console cable and the PC desktop terminal emulation program.

Screenshot CCNA1 Practice Final Packet Tracer Activity

Download

CCNA1-practice-final.zip

Note: You need Packet Tracer version 6.0.1 to open the CCNA1 Practice Final activity.

CCNA 1 Practice Final – Video Tutorials

These video tutorials walk you through my CCNA1 Packet Tracer final. I explain and demonstrate the process of calculating the IPv4 subnets and configuring the IPv6 addressing. I also walk through all of the Cisco router and Cisco switch configurations.

Packet Tracer 6 Activity – Basic IPv6 Network

Overview

This Packet Tracer 6.0.1 and 6.1 networking activity involves setting up a basic IPv6 network by interconnecting two Cisco 1941 routers, two Cisco Catalyst 2960 switches, and two PCs. All of the devices in the network will need to be configured with IPv6 addressing in order to communicate. The goal is to configure the routers and PCs with the following information:

{loadposition adposition5}• On the routers configure basic security with hostnames, console and vty passwords, banner message of the day, and enable password encryption (see the network diagram in Packet Tracer),
• On the routers configure link-local and global unicast IPv6 addresses with network prefix lengths (see the network diagram),
• On the routers configure static IPv6 default routes (see the network diagram),
• On the PCs configure static IPv6 addresses with network prefix lengths, and a gateway address (see the network diagram),
• Follow the instructions in the network diagram for additional required configurations

The scoring is based on the total number of items correctly configured. Remember that when entering configurations the system is case sensitive. When you are finished, you should be able to communicate across the network (e.g. successfully ping PCB from PCA)

Download

BasicIPv6NetworkConfiguration_6.1.zip

Notes: This version fixes the incorrect grading of the IPv6 link-local address of the R2 G0/1 interface You will need Packet Tracer version 6.1 to open this activity

BasicIPv6NetworkConfiguration.zip

Notes: There is incorrect grading of the IPv6 link-local address on the R2 G0/1 interface. Change it to FE80::1 to receive 100%. You will need Packet Tracer version 6.0.1 to open this activity.

 

Spoiler Alert – Only Read Below if you are stuck

IOS Command List

router>enable
router#configure terminal
router(config)#hostname R1
R1(config)#banner motd “No unauthorized access allowed!”
R1(config)#enable secret class
R1(config)#service password-encryption
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#ipv6 unicast-routing
R1(config)#interface g0/0
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:ACAD:2::1/64
R1(config-if)#description toR2
R1(config-if)#no shut
R1(config)#interface g0/1
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#ipv6 address 2001:DB8:ACAD:1::1/64
R1(config-if)#description toLAN
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ipv6 route ::/0 2001:DB8:ACAD:2::2
R1#copy running-config startup-config
R1#show running-config
R1#show ipv6 route
R1#show ipv6 int brief

router(config)#hostname R2
R2(config)#banner motd “No unauthorized access allowed!”
R2(config)#enable secret class
R2(config)#service password-encryption
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#line vty 0 4
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#ipv6 unicast-routing
R2(config)#interface g0/0
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:ACAD:2::2/64
R2(config-if)#description toR2
R2(config-if)#no shut
R2(config)#interface g0/1
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#ipv6 address 2001:DB8:ACAD:3::1/64
R2(config-if)#description toLAN
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#ipv6 route ::/0 2001:DB8:ACAD:2::1
R2#copy running-config startup-config
R2#show running-config
R2#show ipv6 route
R2#show ipv6 int brief

Packet Tracer 6 Activity – Basic IPv4 Network

Overview

This virtual networking activity involves setting up a basic IPv4 network by connecting two Cisco 1941 routers to two Cisco Catalyst 2960 switches to two PCs. The goal is to variously configure the PCs, switches, and routers with the following information:

{loadposition adposition5}• Basic network device security, by configuring access port passwords, banner message of the day and encryption on the routers and switches (see the network diagram in Packet Tracer),
• Interface IP address, subnet mask, and gateway addresses (see the network diagram in Packet Tracer),
• A static default route/gateway of last resort for the routers,
• Follow the instructions in the network diagram for additional required configurations

The scoring is based on the total number of items correctly configured. Remember that when entering configurations the system is case sensitive. In the end, you should be able to ping from PCA to PCB

Download

BasicIPv4NetworkConfiguration.zip

Note: You will need Packet Tracer version 6.0.1 to open this activity

 

Spoiler Alert – Only Read Below if you are stuck

IOS Command List

router>enable
router#configure terminal
router(config)#hostname R1
R1(config)#banner motd “No unauthorized access allowed!”
R1(config)#enable secret class
R1(config)#service password-encryption
{loadposition adposition5}R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface g0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#description toR2
R1(config-if)#no shut
R1(config)#interface g0/1
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#description toLAN
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.2
R1#copy running-config startup-config
R1#show running-config
R1#show ip route
R1#show ip int brief

switch>enable
switch#configure terminal
switch(config)#hostname S1
S1(config)#banner motd “No unauthorized access allowed!”
S1(config)#enable secret class
S1(config)#service password-encryption
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 14
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#interface vlan 1
S1(config-if)#ip address 192.168.0.2
S1(config-if)#exit
S1(config)#ip default-gateway 192.168.0.1

S1(config)#exit
S1#copy running-config startup-config
S1#show running-config